読者です 読者をやめる 読者になる 読者になる

すがブロ

sugamasaoのhatenablogだよ

ruby gems が使えない

gem が使う dll が見つからない><

ruby 1.8 系の環境を作成するにあたり、One-Click Installer ではない ruby バイナリを使う場合、 ruby gems は別途インストールしなくてはいけないのだけど、そこでハマった。
Windows に Ruby on Rails 2.2 + MySQL 5.x 環境を構築する手順とハマり所 - @sugamasao.blog.title # => ”コードで世界を変えたい”の「不足する DLL を追加する」の項目でも書いてある、
- http://jarp.does.notwork.org/win32/
に、以前まであった「openssl-0.9.8d-2-mswin32.zip」が無くなっている!!!!
で、上記の zip ファイルに含まれている dll を要求されてしまい、 gem install xxxx とかした時にエラーになってしまう。

対策は

よくわからんので、One-Click Installer を使うことにした(ぎゃふん)。
というか、これって誰も困ってないのか? どのリンクを調べても gem をセットアップする時は上記のサイトから zip を持ってこいと書かれているが・・・。

追記(2009/6/6)

コメント欄より、下記から zip を取得すると良いらしいです!ありがとうございます!
http://www.deanlee.cn/programming/openssl-for-windows/