読者です 読者をやめる 読者になる 読者になる

すがブロ

sugamasaoのhatenablogだよ

RubyMineでRSpecが動かない場合

ruby

rake で実行するspecタスクは動くんだけど rspec を実行しようとするとエラーが出る

こんな感じ

RSpec support is disabled because 'rspec-rails' gem or RSpec Rails plugin are missing. Install and activate gem at first

ちなみに環境はこう

  • RubyMine 5.4.3.2.1
  • Ruby 2.0.0

で、当然Gemfileにはrspec-railsとかは書いてあってインストールされているにも関わらずこのエラーが出る。RSpec Rails pluginというのはpluginsリストにはない。

どうすれば良いのか

なんか不具合っぽいんだけど、実行するRubyのグローバル環境にrspec-railsが入っていれば動くもよう。 ようするに gem install rspec-rails すると良い。

参考 : http://d.hatena.ne.jp/hikitest/20131102/1383406313